View Issue Details

IDProjectCategoryView StatusLast Update
0000989FS Upgrade Project (Media VPs)Mission Relatedpublic2013-12-19 00:34
ReporterGoober5000Assigned ToMjnMixael 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000989: Exodus (SM3-06) Nebtuu doesn't jump out
DescriptionFrom http://www.hard-light.net/forums/index.php?topic=74389.0

It is possible (though extremely difficult) to protect the GVCv Nebtuu for the entire mission. Unfortunately, the Nebtuu lacks a departure cue which means it will never depart through the node. It'll just sit there.
TagsNo tags attached.

Activities

MjnMixael

2013-12-18 14:03

manager   ~0001238

Last edited: 2013-12-18 14:19

View 2 revisions

You didn't test this one before mantising, did you? Nebtuu has it's departure cue set to <600m from the node center.

Aha, I see. I doubt it actually ever gets that close to the waypoint. I suspect something more robust would be a destroyed-or-departed-delay listing the entire convoy. That way it will warp out if the entire convoy dies as well.

MjnMixael

2013-12-18 14:38

manager   ~0001239

Resolved in Revision 1524.

Goober5000

2013-12-18 21:57

administrator   ~0001240

Yeah, I didn't test any of the reported bugs. I just cross-posted from the internal thread started by "FSU Staff". (Though, for this particular bug, I do remember seeing, in retail, the Nebtuu approach the node and just stop.)

A plain destroyed-or-departed sexp won't cut it, though, because it'll just jump out whether or not it's at the node. The real problem is simply that it heads for a different waypoint than its departure cue. I've corrected this in SVN.

MjnMixael

2013-12-19 00:14

manager   ~0001241

Last edited: 2013-12-19 00:16

View 2 revisions

No. You need to start playing the missions first... seriously.

Assuming the player passes the mission AND keeps the Nebtuu alive, then Nebtuu definitely will be at the node. There is absolutely no way for it not to be... unless it were disabled. In which case, there's nothing to be done for it anyhow. But that situation is even more unlikely.

Now, if the player completely fails the mission and all transports are dead but the Nebtuu is, somehow, still alive... Alpha is ordered to depart. Command would not leave the ship out there to fend for itself. It would depart.

Destroyed-or-departed-delay covers all the necessary (and rare) circumstances that no more time is needed to be spent on this. kthx.

Goober5000

2013-12-19 00:34

administrator   ~0001242

I have played this mission many times in the past, and I examined it in FRED before committing the fix. Stop and think through the problem instead of reacting reflexively.

The Nebtuu is heading toward the "Jump right" waypoint, but it is cued to depart when it is within 600m of the "center" waypoint. The departure cue is mismatched with the AI goals. Now this wouldn't be a problem if the waypoints were next to each other, but as it stands, "Jump right" is 678m away from "center", as seen in FRED. So the Nebtuu doesn't come close enough to trigger the departure cue.

The obvious cause of the bug is that either Volition made a mistake when matching the cue, or they changed the destination waypoint and forgot to change the corresponding departure.

Now the reason destroyed-or-departed is not an appropriate solution is that the Nebtuu is *evacuating* to Epsilon Pegasi, and needs to evacuate through the node whether or not the convoy survives. Destroyed-or-departed makes it jump before it even reaches the node.

Anyway, this is all just documentation. As I said, I've already committed the fix, it's in SVN, it works, so no need to worry about it.

Issue History

Date Modified Username Field Change
2013-12-06 23:20 Goober5000 New Issue
2013-12-06 23:20 Goober5000 Status new => assigned
2013-12-06 23:20 Goober5000 Assigned To => Zacam
2013-12-18 12:38 MjnMixael Assigned To Zacam => MjnMixael
2013-12-18 14:03 MjnMixael Note Added: 0001238
2013-12-18 14:19 MjnMixael Note Edited: 0001238 View Revisions
2013-12-18 14:38 MjnMixael Note Added: 0001239
2013-12-18 14:38 MjnMixael Status assigned => resolved
2013-12-18 14:38 MjnMixael Resolution open => fixed
2013-12-18 21:57 Goober5000 Note Added: 0001240
2013-12-19 00:14 MjnMixael Note Added: 0001241
2013-12-19 00:16 MjnMixael Note Edited: 0001241 View Revisions
2013-12-19 00:34 Goober5000 Note Added: 0001242